VideoScribe Help

Topic not covered?

Start a new topic

System error

I have already paid for this

Suddenly I can not access any menus.

Only the following page is displayed continuously

An error occurred and your request couldn't be completed. 

Click here to go back to the home page

I can't download and also access my account information

4 people have this question

Hey man. I am having the same problem just now, I have raised a ticket and I got a pointless answer, i asked again for help and no response yet. I have sent an email directly to the staff in charge of it and havent gotten any reply either. has your problem been solved? i see that no member of the videoscribe staff replied your ticket either. let me know!

No action has been taken yet.

The problem still remains.

I can't using the program for over a week already. 

I paid for a year. 

It's really annoying.

Seems like you are trying to access the program from website instead of running the program.
You cannot open the program or open or edit you scribes on the website.

close your browser.
run the program and login.

This is just a guess based on the small amount of information provided.

-Mike (videoscribe user)


I already know that.

even the download page can not be accessed

except the first page and the help page, every page is not inaccessible.

I'm not sure I understand your description of the problem.

Have you already downloaded and installed the program? 

Are you having trouble with the program or the website?

You should probably raise a ticket to contact customer support . Explain exactly what you do before you see the error message.

Good luck,
-Mike (videoscribe user)


I have the same problem, I already bought this, I'm trying to download the app but all the URL i went to always redirects me to a page saying 

An error occurred and your request couldn't be completed. 

Click here to go back to the home page

If you click here to go to homepage, it just go back to this error. Go to, same error.

Go to sparkol website? Same error.

It's a hit and miss. 


Have you tried this page for downloading the file?

Are you viewing the website in a language other than english? Maybe the non-english language pages are not working properly.

It might be a good idea to raise a ticket.

-Mike (videoscribe user)

-Mike (videoscribe user)


I came into the same issue, pls fix it ASAP. 

the page still display: System error.

The secure areas of our website require cookies to be enabled and your network to allow verification of them in order to log you in and this error usually means that this is being blocked in some way. Please check your cookies and network settings as a first port of call. 

A good way of making sure it's not a specific account issue for you would be to log-into the website on your SMART phone over 4G as this will check a different browser, device and network at the same time. 

To mitigate this we have placed a download page outside of the log-in process and this can be accessed via

Any customer who believes that they have an issue with their account specifically please log a support ticket and we can investigate it for you in more detail -

Hi Barry, even the download page you gave resulted in the same error. Its not an account issue since I cant even go to the login page without encountering this problem. I wonder why this only happens with any of sparkol/videoscribe URL except for the help section.

I'm sure other websites such as online banking has the same security features, and they work just fine.

I can see you've logged a support ticket, we have sent you a few suggestions there and if you can reply when you have tried those we will continue to work on getting this fixed for you.

Hi , i have taken quarterly paid version of videoscribe and i m not being able to use the image section of same.

Please help me as i have to shutdown the laptop after opening images section.  

Hi Pawan,

Sorry that you are having this issue.

Please follow the steps in the article Add image button does not work for a possible solution. If that doesn't help, please let us know.

This implies I can actually log in and download the product.

If I just go to - I get the System Error page shown above, the same if I go to, however, I can get to, and I can get to the help pages (obviously).

I have had people in my organisation get to your webpage so its not a problem on our end (we think). It needs you direct intervention or some advice on how to resolve

Paul M

Login to post a comment