VideoScribe Help

Device compatibility and systems requirements

Last updated: 18 January 2018

For StoryPix to function correctly you will need to ensure your device meets the following minimum requirements

Device support:

  • Andoid touchscreen tablets (4.4 or higher)
  • iPad (any device that can support iOS 11+)
  • Kindle Fire 10

Browser support:

  • Chrome v49 (Android only)
  • Firefox v55
  • Safari 11 (iPad only)
  • Silk (Kindle Fire only)

At this time StoryPix does not support mobile phones and desktops PCs. However, we are working on this and hope to have it available soon

Did you find it helpful? Yes No

Can you please tell us how we can improve this article?

Related articles